以沫

易语言扫描二维码
大家在使用易语言编写软件的时候都因为怎么扫描二维码而为难过吧,这里推荐一款DLL帮助你一键识别二维码!
扫描右侧二维码阅读全文
30
2019/08

易语言扫描二维码

大家在使用易语言编写软件的时候都因为怎么扫描二维码而为难过吧,这里推荐一款DLL帮助你一键识别二维码!

  首先,我们需要一款DLL作为辅助!
  下载地址:[本地下载][1]、[蓝奏网盘][2]
  压缩包密码以及蓝奏网盘链接密码:

此处内容需要评论回复后(审核通过)方可阅读。

然后,我们执行扫描的代码如下:


.版本 2
.支持库 spec

.子程序 解码, 文本型
.参数 strFilePath, 文本型
.局部变量 intOldPointer, 整数型
.局部变量 lngResult, 整数型
.局部变量 strResult, 文本型
.局部变量 i, 整数型
.局部变量 lngCount, 整数型
.局部变量 lngSeqNo, 整数型
.局部变量 byCheckDigit, 字节型
.局部变量 lngPosition, 整数型, , "8"

.如果 (blnEnableSetRect)
    lngResult = DecodePictureFileRect (strFilePath, lngRectLeft, lngRectTop, lngRectRight, lngRectBottom)
.否则
    lngResult = DecodePictureFile (strFilePath)
.如果结束

.如果 (lngResult ≥ 1)
    .变量循环首 (0, lngResult - 1, 1, i)
        strResult = strResult + “——————————————————————” + #换行符
        strResult = strResult + “已解码数据 ” + 到文本 (i + 1)
        strResult = strResult + “ [模型版本: ” + 到文本 (GetDecodeVersion (i))
        strResult = strResult + “, 等级: ”
        .判断开始 (GetDecodeLevel (i) = 0)
            strResult = strResult + “L(7%)”
        .判
Last modification:August 31st, 2019 at 11:34 am
以沫也要恰饭哒~~~

One comment

  1. 皮蛋

    9999真好用,谢谢

Leave a Comment